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Tag Browser 
Introduction 

The Universal OPC Tag Browser is a tool that allows you to create displays in the five main 
applications in ProcessView: GraphWorX, TrendWorX, AlarmWorX, DataWorX, and ScriptWorX. 
Using the Tag Browser, you connect to the OPC server, find the available tags needed to configure 
the type of display that you wish to build, and send them to Smar or third-party OPC clients. 

A tag (sometimes called a "point") is a specification that, once sent to a client, will direct your 
customized software to perform a desired function. For example, a tag can direct your TrendWorX 
program to provide trending information at pre-determined intervals of time. 

Using an intuitive point-and-click interface, the Tag Browser lets you: 

• Configure OPC Data Access (DA) points (or tags). 

• Obtain OPC Alarm and Events (AE) server information. 

• Configure OPC Historical Data Access (HDA). 

 

The Tag Browser performs the functions listed above for Smar OPC clients and OPC third-party 
clients that support drag-and-drop, an OPC specification. To accomplish this, the Tag Browser uses 
the OPC interfaces to connect to OPC data servers through COM and DCOM. This connection also 
allows the Tag Browser to support network tag configuration without additional user configuration 
being necessary. 

Launching the Tag Browser 
To launch the Tag Browser from the Windows Start menu, select Programs > Smar > 
ProcessView > Tools > OPC Tag Browser. 

Note 
You can also launch the Tag Browser from many dialogs within the ProcessView applications. 

Features of the OPC Universal Tag Browser 
The Tag Browser consists of a single dialog box with two panes, as shown in the figure below. The 
important features of the OPC Universal Tag Browser are: 

• The dialog box is resizable. 

• The split bar is movable. 

• The most recent information displayed and the tree location are maintained even after you have 
closed the dialog box. 

• For quick configuration, a list of previously selected points is available in a drop-down list in the 
Item Id field. 

• The tree control will update a branch's child information by highlighting the branch in the tree 
control and clicking the Refresh button. 

• Copying the registry information to the local computer is not necessary for network 
configuration. 

• The user interface of the Tag Browser presents a hierarchical tree control display of 
information. The tree includes information on network location, server name, and group hierarchy. 
This view also lets you create a tag name based on server location and group names. As a result, a 
remote client PC can configure tags from the OPC data servers. The only special setup required to 
support this remote browsing are network connections. 

• Support for multiple tag selection. (Available only for specific applications.) 



Tag Browser 

2 

 

Figure 1. OPC Universal Tag Browser 

 

The Item Id field displays the name of the currently selected tag. You can also select a previously 
used tag name from the drop-down list. The Filter field displays any relevant strings (available only 
for OPC data servers that support filtering). 

Tag Name Designations 
In the right pane of the Tag Browser, the tag name columns on each bar are as follows:  

Type: Specifies the data type for the OPC item. Valid values include int, long, double, etc. 

Description: OPC item's description retrieved from OPC server. 

Eng Units: Specifies the label to use in displays to define the units for the OPC item (e.g., kg/sec). 

Node: Specifies the machine that is the source for the item. This is intended to be the broadest 
category for defining sources. For an OPC Data Access Server source, this is the node name or IP 
address of the server. For non-OPC sources, the meaning of this field is server-specific. 

ItemID: Specifies the qualified OPC item id. This is used to allow filtering in the CreateBrowse 
method. 

User Interface 
The Tree view of the Tag Browser, shown in the figure below, is created on the fly. "On the fly" 
means that, when you click on the OPC server of your choice, the Tag Browser queries the server 
on the type of hierarchy it supports. The Tag Browser then determines how to display the hierarchy. 
It will be either a "flat view" (i.e., vertically straight up and down) or a "tree view" (i.e., with 
"branches" descending out of one another) hierarchy, depending on the type the server supports. 
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Figure 2. Tag Browser User Interface: Hierarchical Tree View and List View 

Your creation of a view is based on a request algorithm designated to decrease delays in reading 
large browse databases. To filter the displayed tree and list information, you can also type a string 
into the Filter field (available only for OPC data servers that support filtering). All items associated 
with a selected group folder in the Tree view (left pane) appear in the List view (right pane). 

Tag Browser Functions 
The following table describes the different Tag Browser functions and fields. 

Parameter Description 

Item ID The fully resolved, or complete, tag name. (See the figure below.) (Note: 
On network or Internet servers, the node name appears at the beginning 
of the tag name.) 

Filter Sends a filter to the OPC server once you have entered a string in the 
Filter field (available only for OPC data servers that support filtering). 

Tag Names Displays information in Item Id box if you double-click on or highlight the 
list of tag names available.  

Cancel Closes the dialog box.  

Refresh Updates the branch and associated list once you have highlighted a 
branch in the Tree view and clicked on this button.  

OK Passes configuration information to the calling application. 

Details Available only after you have launched a server. Displays additional 
information on the selected OPC server. 

Add Branch Adds all branch information to the Bottom List control. Available only in 
Multiple Tag Selection mode. 
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Parameter Description 

Add Item Adds selected item information to the Bottom List control. Available only 
in Multiple Tag Selection mode. 

Remove   Removes selected item information from the Bottom List control. Only 
available in Multiple Tag Selection mode. 

Remove All Removes all item information from the Bottom List control. Only 
available in Multiple Tag Selection mode. 

About Launches the About Box, which contains information about the product 
version number, copyright, and available disk space. It also contains 
information about how to contact Smar. 

Help Launches the online help for the Tag Browser. 

Debug Used for developers to help debug OPC browser calls. 

Item Id 
Name/Tag 
Name List 
Control 

Used to store items information to pass to the calling application. Only 
available in Multiple Tag Selection mode 

 

 

Figure 3. Parts of a Complete Tag Name on a Local Server 
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Operating the Tag Browser 

Single Tag Selection Mode 
Single Selection mode allows you to select one tag at a time from the server and have it sent to 
the client that has requested it. 

To operate the OPC Universal Tag Browser in Single Selection mode in the GraphWorX, 
TrendWorX, AlarmWorX, DataWorX, and ScriptWorX applications, follow the steps below: 

 

In GraphWorX: 

1. Start GraphWorX by clicking on the Start button and selecting Programs > Smar > 
ProcessView > GraphWorX > GraphWorX. 

2. In the Dynamics menu, select Intrinsics > Process Point, then click anywhere on the blank 
screen. The Property Inspector dialog box appears. 

3. Click on the OPC Tags button on the Property Inspector dialog box. 

4. The OPC Universal Tag Browser dialog box appears. To continue, follow the directions given 
in Steps1-6, below. 

 

In TrendWorX: 

1. Start TrendWorX by clicking on the Start button and selecting Programs > Smar > 
ProcessView > TrendWorX > TrendWorX. 

2. In the File menu, select New to create a new display on the screen. 

3. Double-click on the new display. The Trend Viewer ActiveX Properties dialog box appears. Click 
on the Pens tab. 

4. On the Pens tab, click the OPC Tags button. The OPC Universal Tag Browser dialog box 
appears. To continue, follow the directions given in Steps1-6, below. 

 

In AlarmWorx: 

1. Start AlarmWorX by clicking on the Start button and selecting Programs > Smar > 
ProcessView > AlarmWorX > AlarmWorX. 

2. Double-click on the AlarmWorX View ActiveX object. The Alarm Viewer ActiveX Properties 
dialog box appears.  

3. Click on the Subscription tab. Click the Add button and name the new subscription. 

4. Double-click on the new subscription name. The Event Subscription dialog box appears. 

5. On the Event Subscription dialog box, click on the Browse button. 

6. The OPC Universal Tag Browser dialog box appears. To continue, follow the directions given 
in Steps1-6, below. 

 

In DataWorX: 

1. Start DataWorX by clicking on the Start button and selecting Programs > Smar > 
ProcessView > Tools > DataWorX. 

2. On the main Toolbar, select Add from the Register menu. The Register Settings dialog box 
appears. 

3. Click on the Outputs tab, then on the Tags Menu button. Select OPC Tags from the pop-up 
menu. 
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4. The OPC Universal Tag Browser dialog box appears. To continue, follow the directions given 
in Steps1-6, below. 

In ScriptWorX: 

1. Start ScriptWorX by clicking on the Start button and selecting Programs > Smar > 
ProcessView > ScriptWorX. 

2. On the File menu, select New.  

3. A window will appear. In the left pane, click on VBA Script Triggers. The list of Scripts folders 
will drop down. 

4. Right-click on Event Scripts, and then click Insert Trigger. A dialog box will appear in the right 
pane. 

5. Click on the Expression Editor button. The Edit Expression dialog box appears. 

6. Click on the Tags button. 

7. The OPC Universal Tag Browser dialog box appears. To continue, follow the directions given 
in Steps1-6, below. 

 

Continued Directions for operating the OPC Universal Tag Browser in Single Selection mode: 

1. Double-click on My Computer in the tree view of the Tag Browser dialog box. 

2. Double click on Data Access. 

3. Double-click on the OPC Server of your choice. This launches the server and present a list of 
item groups in the form of folders. 

4. In the tree view, browse by either by clicking the mouse on the list of groups folders or keying 
up or down. The contents of each folder in the groups list will automatically appear in the right-hand 
list view. These contents are the names of tags (also called "points"). 

5. In the list view, double-click on the desired tag name or highlight it and click OK. Now you have 
selected a tag. The Tag Browser then resolves the tag name; adds the tag to the drop-down box of 
the Item ID field (as shown in the figure below); passes the tag name to the calling client; and 
closes the dialog box. 

6. Alternatively, select a complete tag name previously configured in the drop-down box of the 
Item ID field or manually type the complete tag name in the Item ID field. Type the tag name in the 
following format: "//node name/server name/ item id." For local servers, type in: "server name/item 
id". 

7. Once a string is selected, click OK to finish point configuration. 

8. To allow for easier configuration, enter a string in the Filter field to send a filter to the OPC 
Data server (only available on OPC Data servers that support filtering). 

 

Multiple Tag Selection Mode 
The Tag Browser also supports multiple-tag configuration for specific Tag Browser operations. OPC 
Historical Data Access is one of those operations. 
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Figure 4. Multiple Tag Selection Mode 

1. Double-click on My Computer in the Tag Browser, as shown in the figure above. This expands 
the branches. 

2. Double-click on HDA. The Tag Browser creates a list of OPC History Data Access servers. 

3. Select an HDA server and double-click on it. The Tag Browser launches the selected server 
and query for browse information. 

4. Select an item or items from the right pane (List view) and click Add Item. The information is 
added to the bottom list control. 

5. It is possible to select an entire branch of information. To do this, select the appropriate branch 
from the tree control and click Add Branch. This will cause all items associated with the branch to 
be added to the bottom list control. 

6. To remove an item from the bottom list control, select the item or items and click the Remove 
button. 

7. To remove all items from the bottom list control, click Remove All. 

8. Once all desired items have selected, click OK. 

Internet Access to the Tag Browser: GenBroker 
To make the Tag Browser accessible through the Internet, Smar has enhanced ProcessView with 
GenBroker, a proven, high-speed communications utility. Employing a network of applications, 
GenBroker uses OPC over TCP/IP communications channels to achieve real time and secure 
communications between Web servers and Web browser clients. Everything except the method of 
communication method remains the same as before. For more information, please refer to the 
GenBroker help documentation. 

Click on the Internet tree to view the nodes and tags available through GenBroker communications 
channels, as shown in the figure below. Tag names browsed through a remote server will have the 
following syntax in the Item Id field: "//node name/server name/ item id." 
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Figure 5. Internet Access Through the Tag Browser 

 

 


